c 라이브러리 gl이 설치되어 있어야합니다


0

dangerdeep을 설치하려고합니다.웹 사이트와 scon 디버그에서 제안한 의존성을 설치 한 후 c 라이브러리 gl을 설치해야한다는 메시지가 나타납니다.우분투 12.04와 함께 일하고 있습니다

1

I'm not sure what you tried already... For me it seems like this would solve your problem:

sudo apt-get install libopengl-dev

0

I'm using Ubuntu 14.04 and successfully installed dangerdeep.

I found that if you open ~/dangerdeep/SConstruct with sudo privileges and edit line 263 to only search for libGL.so in the folders /usr/X11R6/lib/, /usr/lib/ and /usr/local/lib/, itsolves my problem.

In Ubuntu 14.04 you can find it in /usr/lib/i386-linux-gnu/mesa/

and add the folder to the 263 line, using:

gllibdirs = ['/usr/X11R6/lib/', '/usr/lib/', '/usr/local/lib/', '/usr/lib/i386-linux-gnu/mesa/']

then try install it again!