python-pip를 설치할 수 없습니다


1

패키지를 설치할 수 없습니다.'sudo apt-get install python-pip python-dev build-essential'명령으로 시도했습니다.그리고 나는 출력을 얻었다 :

패키지 목록을 읽는 중 ... 완료의존성 트리 구축
상태 정보를 읽는 중 ... 완료build-essential은 이미 최신 버전입니다 (12.1ubuntu2).빌드 필수는 수동 설치로 설정됩니다.python-dev는 이미 최신 버전 (2.7.11-1)입니다.python-dev가 수동으로 설치되었습니다.일부 패키지를 설치할 수 없습니다.이것은 당신이 가지고 있음을 의미 할 수 있습니다불가능한 상황을 요청했거나 불안정한 경우일부 필수 패키지가 아직 작성되지 않은 분배또는 수신에서 제외되었습니다.다음 정보는 상황을 해결하는 데 도움이 될 수 있습니다.

다음 패키지는 충족되지 않은 종속성을 가지고 있습니다.python-pip : 의존합니다 : ca-certificates하지만 설치되지 않을 것입니다python-pip-whl (= 8.1.1-2ubuntu0.4)에 따라 다르지만 설치되지 않습니다.E : 문제를 해결할 수 없어서 깨진 패키지가 있습니다.

적절하게 설치하려고했는데

다음과 같은 새로운 패키지가 설치됩니다 :ca-certificates {a} libpython-all-dev {a} openssl {ab} python-all {a}python-all-dev {a} python-pip python-pip-whl {a} python-wheel {a}패키지 업그레이드 0 개, 새로 설치 8 개, 제거 0 개, 업그레이드 3 개1,988 kB의 아카이브를 가져와야합니다.개봉 후 3,537 kB가 사용됩니다.다음 패키지는 충족되지 않은 종속성이 있습니다.openssl : 종속 : libssl1.0.0 (> = 1.0.2g)이지만 1.0.2d-1이 설치되어 있습니다.다음 조치는 이러한 종속성을 해결합니다.

 Keep the following packages at their current version:

1) CA 인증서 [설치되지 않음]
2) openssl [설치되지 않음]
3) python-pip [설치되지 않음]
4) python-pip-whl [설치되지 않음]

이 솔루션을 수락 하시겠습니까?[Y / n / q /?]

Y를 입력 한 다음

패키지는 설치, 업그레이드 또는 제거되지 않습니다.패키지 업그레이드 0 개, 새로 설치 0 개, 제거 0 개, 업그레이드 3 개0B의 아카이브를 가져와야합니다.포장 풀기 후 0 B가 사용됩니다.

작동하지만 작동하지 않으면 다음 링크를 참조했습니다

Ubuntu 14.04, problem when install gstreamer1.0-libav, unmet dependencies

How do I resolve unmet dependencies after adding a PPA?

Ubuntu unable to install any packages, held broken packages

죄송 합니다만, 내가 한 일을 모르지만 정말 엉망인 것 같습니다.그러나 apt-get을 통해 numpy 등과 같은 패키지를 직접 설치할 수있었습니다.

2

You broke your system by unwisely installing software from a non-Ubuntu source.

Lots of good clues in the error message:

openssl : Depends: libssl1.0.0 (>= 1.0.2g) but 1.0.2d-1 is installed

libssl1.0.0 1.0.2g is in the Ubuntu 16.04 repositories.

libssl1.0.0 1.0.2d-1 is not in Ubuntu (nor Debian). You installed it from somewhere else.

To fix the problem, disable the non-Ubuntu source. Then uninstall ALL packages from that source. Refresh your package database (sudo apt update) because your sources have changed. Test your package manager for proper function (sudo apt upgrade). Then re-install the packages you need from the Ubuntu repositories.


0

As pointed out by user535733 libssl1.0.0 seems to be missing, therefore by installing it with command:

sudo apt-get install libssl1.0.0/xenial libssl-dev/xenial openssl/xenial

seems to have solved the problem