耳機沒有聲音Ubuntu 16.04


1

所以從在單獨的分區上安裝ubuntu那天開始,我就遇到了這個問題。我從筆記本電腦收到聲音,但從耳機聽不到聲音,通常我會重新啟動筆記本電腦2-3次,並且恢復正常運行一周左右,但是這次重新啟動10次後,並不能解決問題。我知道這是Ubuntu 16.04的錯誤,但是有人找到了解決方案嗎?到目前為止,這是我所做/調查的事情:

pavucontrol表明,如果我播放youtube中的視頻,則耳機正在檢測聲音,但沒有聲音。

總體聲音設置表明它們可以檢測到我的耳機。

我也運行了update和dist-upgrade,什麼也沒有。

0

Try that :
In Pavucontrol, "output device" tab:
when headphones are connected , you logically see "headphones" in output port:
but try to switch port to "speakers" .

This worked recently for me on a HP 820 g1.
Real fix is to use hdajackretask to modify bad audio feed to headphone, but it depends on your hardware .


0

I have the same issue. I simply restart (kill) the sound daemon that I am using on my laptop (Lenovo ideapad 100 on Ubuntu 16.04.2 LTS).

In the terminal, I run this:

pulseaudio -k

0

I don't know the reason why, but on my laptop I can use the regular headphone jack on a fresh boot.

But after a suspend I need to move my headphones to the Line Out jack. If I use the headphone jack I don't get any sound. When I try to play a sound I can see the Output Device volume meter moving but don't hear anything.

If I unplug the speakers kick on, as expected. Plug back in and nothing. But if I move the headphones to the other jack it works.

I don't know what the icon is supposed to mean, but it looks like a squared off sine wave with an arrow aiming out which is why I called it Line Out.

That might help somebody.

EDIT: I figured out that it's the S/PDIF Out Jack that works for me.


0

I have the same problem on my 2 laptops with latest Ubuntu 16.04.

The next steps helped me:

  1. Power Off your laptop.

  2. Unplug Headphones from the jack.

  3. Power On your laptop.

  4. Only after the Login procedure, plug in your headphones.

I hope this helps you.


0

My advice is to update the linux kernel inside ubuntu 16.04. I once clicked on install updates which did modifications to the operating system and also updated the kernel to a newer version, that was also the reason why my headphones didn't work, speaker audio was fine tough. After I followed this guide:

https://wiki.ubuntu.com/Kernel/LTSEnablementStack#Ubuntu_16.04_LTS_-_Xenial_Xerus

about how to update the linux kernel to the very newest available version and rebooted once the headphones work fine again.

I used this command: apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04